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Maya’s particle system is a powerful and extensive collection of tools and 
features used to simulate a variety of effects such as dust, sand, fire, clouds, 
explosions, smoke, and liquids. Effects such as these are found in countless 
feature film and broadcast shots and have become part of the every day effects 
for many in the industry.

This tutorial explains how to set up and render a rocket launching. The focus is 
on setting up the smoke trail of the rocket using software particles. 

In this tutorial:

• Particle objects versus geometry... page 2 

• Adding a Thrust emitter... page 2 

• Adjusting particle attributes... page 5 

• Adding fields... page 6 

• Changing each particle’s radius over time... page 9 

• Animating the emission rate... page 12 

• Rendering the scene... page 13 

• Lighting and global settings... page 16 
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Rocket launch—Introduction
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Rocket launch—Introduction
To create the smoke trail in the image, three different particle objects have slightly different 
motion and shading characteristics. All three particle objects are emitted from one emitter that is 
parented to the rocket. 

Thick particles: Provides a base layer of particles resulting in a chunky display.

Softer particles: Provides a layer of wispiness.

Trail particles: Used to simulate the streaking effect in the smoke trail.

Once you tune the particles’ motion and emission using fields and animation curves, you add 
lighting and shading and then render the scene.

Particle objects versus geometry
The differences between Maya’s particles and geometry are:

• Particles are points in space. They require special handling when rendering since they do not 
contain surface information.

• Particles can be rendered using hardware or software rendering methods. You can choose a 
method using the Render Type attribute (see Set the Particle Render Type and render attributes 
for details). 

The rocket example uses software render types only. Although software render types render 
slower, details such as shadows, detailed texturing, and reflections can be rendered.

• In Maya, individual particles belong to a common collection called the particleShape object. 
Just as CVs of a geometric object belong to their shape node, individual particles are like 
components to the particleShape node.

Adding a Thrust emitter
A particle emitter is like a cannon that fires particles into space. The following shows you how to 
add an emitter.

Before you start:

This tutorial requires Maya scene files. To download the tutorial files, please visit the 
Taste of Maya web site at www.aliaswavefront.com/tasteofmaya.

Starting Maya:

Double-click the Maya 3.0 Evaluation icon on the desktop, or from 
Start > Programs > Maya 3.0 Evaluation > Maya.

In Maya:

Once the tutorial files have been installed, set the current project to access the Maya 
scene files. To set the current project from within Maya:

• Select File > Project > Set and navigate to the directory where you installed the 
Maya scene files. 

• Select the directory Maya_tutorial_data and press OK.
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Adding a Thrust emitter
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Open the scene file and play it back

1 Select File > Open.

2 Select rocket_start.ma.

This scene file contains a rocket on a launch pad. The rocket launch has already been keyframed. 
Playback to see the rocket launching.

Add a directional emitter

1 Press F4 to access the Dynamics menu set.

2 In the Outliner, select thrust (within the rocket group).

3 Select Particles > Emit from Object ❐  and set the following in the window that displays:

4 Press Create.

Set... to...

Emitter Name thrustEmit

Emitter Type Directional

Rate 45 The number of particles emitted per-second.

Max Distance

Min Distance

5

1

Min and Max Distance determines a distance from
the emitter in which emission can occur. The values
used here keep the particles from overlapping with
the tail of the rocket.

Spread 0.15

Direction X, Y, Z -1, 0, 0 respectively

Speed 150 Controls how quickly the particles leave the 
emitter.
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View and rename the particle object 

1 Press play on the Time Slider to watch the particles emit.

Particles trailing behind the rocket

2 Open the Outliner to see the new particle1 particle object and the thrustEmit emitter.

3 Double-click particle1 in the Outliner and rename it to thick.

Outliner showing emitter and associated particle object

4 Select the particle object and set Level of Detail to 0.25 in the Channel Box.

Tip 

Make sure Playback Speed is set to Free or the emitter may appear to sputter particles instead 
of provide a constant emission (Window > Settings/ Preferences > Preferences > Timeline).
4 A TASTE OF MAYA  2001, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this 
tutorial, you have agreed to the terms and conditions which can be found in the tutorial’s 
installation executable available from www.aliaswavefront.com/tasteofmaya.



ROCKET LAUNCH

Adjusting particle attributes

To send us your questions and feedback, please visit
www.aliaswavefront.com/tasteofmaya
To work with particles efficiently, use Level of Detail (LOD). Level of detail controls the 
percentage of particles displayed in the views and in the final render. Lowering this value lets 
you quickly evaluate motion while testing.

Remember to set this back to 1 when rendering.

Adjusting particle attributes
Now that the emitter is in place, you can begin to make a few preliminary changes to the 
particles to make them more visible and behave like a realistic smoke trail.

Adjusting particle attributes in the Attribute Editor
You adjust most particle attributes in the Attribute Editor for the thickShape object. Changes 
made here affect every particle component belonging to the selected particle object.

Adjust attributes for thick particles

1 Continue from the last step, or open rocket_thick.ma. 

2 Select thick in the Outliner. 

3 Press Ctrl-a to open the Attribute Editor.

Set the Particle Render Type and render attributes

1 In the Render Attributes section of the Attribute Editor, set the Particle Render Type to 
Cloud.

2 Click the Current Render Type button. Attributes associated with the cloud render type 
display. 

3 Change the following settings:

• Surface Shading to 0.8

• Threshold to 8.250

These settings control several rendering properties for the clouds (which will be more important 
later on). You will not see any change in the perspective view.

Note

To create a stand-alone emitter that does not get placed within an object hierarchy, you can use 
Particles > Create Emitter. You can still parent this emitter to an object later if desired.
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Setting thick particles to cloud and adjusting attributes

Add a per-object lifespan 

Adding a lifespan attribute lets you control how many seconds each particle is displayed in the 
scene. To do this:

In the Lifespan Attributes section of the Attribute Editor, set Lifespan Mode to Constant and 
Lifespan to 5.

Adding fields
Fields act like forces that move the particles around in different ways. At this point of the 
tutorial, you add gravity, turbulence, and radial fields and connect them using three different 
methods.

Method 1

Create gravity and connect it 

The following shows you how to create a stand-alone field and connect it to the particles to make 
them look realistic when they fall.

1 Make sure nothing is selected.

2 Choose Fields > Gravity.

3 In the Outliner, select the thick particles, then Ctrl-select the gravityField1.

4 Select Fields > Affect Selected Objects to connect the gravity field to the particles. 

If you switch to wireframe mode (press 4) and select only gravityField1, the particles highlight 
in pink to indicate the connection.

Adjust the particle conserve attribute

Playback the scene. As you playback, notice how the particles quickly fall instead of float. To 
simulate ejecting and easing to a stop, you can adjust the amount of momentum the particles 
conserve at each frame.

1 Open the Attribute Editor for thickShape.

2 In the Thrust Emit section, set the Speed to 25.

3 Adjust the Conserve attribute near the top of the Attribute Editor. A value of 0.5 works 
well. 
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This means that at each frame each particle keeps only 10 percent of the velocity it had in the 
previous frame. Try experimenting with other conserve values.

Method 2

Create turbulence and connect it using dynamic relationships

The following shows you how to apply turbulence to scatter the particles a bit, and use the 
Dynamic Relationships Editor to connect the field. This editor can be used to manage many 
types of dynamics connections including fields, collisions, and emission.

1 Rewind to Frame 1 and make sure nothing is selected.

2 Select Fields > Turbulence ❐  to open the options window and set the following:

• Magnitude to 100

• Attenuation to 1

3 Press Create.

An Attenuation of 1 causes the field influence to diminish over distance, which means that 
particles further away from the field are less turbulent.

4 Press w to enter the Move tool.

5 Move the field’s icon to roughly the same location as the thrustEmit object (near the back 
end of the rocket).

6 With the field still selected, Ctrl-select the thrust geometry object in the Outliner (not the 
emitter), then select Edit > Parent to make the field follow along with the rocket.

Parenting of turbulence field in Outliner

7 Select Windows > Relationship Editors > Dynamic Relationships.

8 Make sure the Selection Mode is set to Fields.

9 Select thick on the left side and turbulenceField1 on the right. gravityField1 is also 
highlighted on the right confirming that it is connected.
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Gravity and turbulence connected in Dynamic Relationships Editor

Method 3

Add a radial field to push the particles outward

The following shows you how to slightly expand the particles after they leave the rocket by 
adding a radial field.

1 Select thick in the Outliner.

2 Open the Add Radial window (Fields > Radial ❐ ) and set the following:

3 Press Create.

4 Turn on Apply Per Vertex in the Channel Box.

Set... to...

Magnitude 0.8

Attenuation 0.5

Use Max Distance On

Max Distance 8

Tip 

You use Add Radial to automatically parent the field to the particles. Turning Apply Per 
Vertex on causes individual particles to behave as though independent radial fields are 
attached to it. This keeps all the particles pushing away from each other.
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Changing each particle’s radius over time
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5 To connect thick particles to radialField1, use the Dynamic Relationships window 
(Window > Relationship Editors > Dynamic Relationships).

6 Playback to test the motion.

To see a completed version of the scene file up to this point, open rocket_with_fields.ma.

Particles pushed away from the center by a radial field

Changing each particle’s radius over time
At this point, every particle in thick has the same radius (1.0). You can give each particle its own 
radius value and change that value over the course of the particle’s lifespan. This is done by 
adding a per-particle radius attribute (radiusPP) which is controlled by a ramp. For example, the 
particles can exit small, then grow, then get smaller again by the time they die, which is similar 
to how puffs of smoke behave.

Add radiusPP to thick in the Attribute Editor

1 Select thick and open the Attribute Editor.

2 Click the thickShape tab at the top of the Attribute Editor.

3 Click the General button under Add Dynamic Attributes.

4 Click the Particle tab on the window that displays, select radiusPP and press OK.
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Changing each particle’s radius over time
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Adding a radiusPP attribute

radiusPP shown in thick’s Attribute Editor

Note 

The particles disappear because radiusPP is set to 0. When both radius and radiusPP attributes 
exist, the radiusPP values override the radius attribute.
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Assign a pre-made ramp to thick’s radiusPP

Since radiusPP is currently 0, you have to assign a value so the particles can grow and shrink. A 
quick way to do this is to assign a pre-made ramp. (A ramp is just a gradation between values.)

1 In the Attribute Editor for thick, RMB in the field next to radiusPP, and select the box beside 
Create Ramp to open the Create Ramp options window.

Selecting a pre-made ramp from the Create Ramp Options window

2 Select RadiusRamp from the Map To pull-down menu. This gradation of values has been set 
up for you so the radius grows and shrinks at the right times. 

3 Leave InputU and InputV as they are and press OK.

4 Rewind and play back the scene. The rocket_radiusPP.ma file contains a setup version of 
the scene up to this point.

Particles with changing radius values
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Animating the emission rate
A rocket exudes more smoke at initial take off. To simulate this, you have to animate the 
emission rate on the thrustEmit emitter.

Continue from the previous steps, or open rocket_radiusPP.ma, which can be used as a starting 
point.

Keyframe thrustEmit rate

1 Select Windows > Saved Layouts > Persp/Graph/Outliner.

2 Select thrustEmit and open the Channel Box.

3 Go to frame 18 on the Time Slider.

4 Set rate to 0 in the Channel Box.

5 RMB click on rate in the Channel Box and choose Key Selected to keyframe the rate to 0 at 
frame 18.

6 Set four more keyframes using the following values:

• frame 22: rate = 10

• frame 26: rate = 6

• frame 39: rate = 40

• frame 70: rate = 0

The goal is to create an animation curve in the Graph Editor resembling the following:

Emission rate controlled by animation curve in the Graph Editor
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Keyframed emission rate result

Rendering the scene
This part of the tutorial shows you how to render the particles to resemble smoke. The scene file 
provided contains additional particle objects and lighting. Your task is to assign the appropriate 
shaders to the particles.

File contents
Select File > Open Scene and open the rocket_render.ma file. This file contains additional 
particle objects, display layers, and two volumetric particle cloud shaders. See the following 
descriptions. 

Additional particle objects

Emit from the same emitter as the thick particles.

• softer: These particles are slightly larger than the thick particles.

• trail: The length of these Tube render type particles are determined by how fast they move. 
These particles create trailing streaks behind the rocket.

Note 

The last two keyframes in the image use stepped tangents. For more information about adjusting 
keyframe tangents and weights in the Graph Editor, see the on-line documentation. 

Tip 

If there are too many particles to see what is happening, or if the playback is too slow, you can 
temporarily lower the emission rate in the Graph Editor, or lower the Level Of Detail attribute 
on the particle object. Temporarily setting the Render Type to Points can also help.
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Display layers

Provided for each particle object. Use these display layers to turn the visibility of the particles on 
and off. This helps you manage the number of particles displayed on the screen and speeds up 
the test renders.

Volumetric particle cloud shaders

• thickCloud: Provides a chunky-edge appearance to the thickParticles.

• softCloud: Assigned to softer and trail particles. More transparent than thickCloud, this 
provides a softer boundary overlaying the thickCloud and tones down the brighter 
highlights.

Assigning Shaders for the Particles in Hypershade

You use Maya’s Hypershade to build and assign materials (sometimes called shaders) to the 
particles.

1 Open Windows > Outliner and select thick.

2 Shift-select the thickClouds material icon in Hypershade (Window > Hypershade).

3 RMB on the thickCloud icon’s text label and select Assign Material to Selection from the 
pop-up menu that displays.

4 Repeat the process for softer and trail except assign the softCloud material to both of them.

RMB menu for assigning shaders in Hypershade

Tip—Render speed considerations 

While performing test renders, render speed is greatly affected by the number of particles and 
the percentage of screen space those particles occupy. It is recommended that you frame the 
scene for test renders, and don’t forget to use the Level of Detail attribute and the display layers 
to help manage rendering speed.
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Test rendering individual layers
To get an idea of what each material and particle object is contributing to the image, use the 
display layers to display only one particle object at a time, then render a frame. 

Test render layers

1 Make sure the layer bar is displayed (Display > UI Elements > Layer Bar).

2 From the Time Slider, play up to frame 40. 

3 To hide softer and trail from the layer bar, RMB in the Layer Bar and turn off visibility for 
softerLayer and trailLayer.

4 In the Render View (Window > Rendering Editors > Render View), choose 
Render > Render > Current (persp).

5 Repeat the process (two particle layers hidden, one visible) to render one still image of each 
particle object.

6 Test render a frame with all three particle objects visible so you can see how they display 
when combined. See the following examples.

Tip 

When adjusting materials, try to focus on one particle object at a time. This keeps rendering 
times lower and helps you see what is going on. 

Tip 

Press the 1:1 button in the Render View to view the Render at the accurate aspect ratio.

Default shading Thick

TrailSofter

Thick, Softer, and Trail Combined

The default particle material and each particle object rendered.

Three particle layers combined.
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Lighting and global settings
Other options are important to consider when rendering this type of shot in Maya, such as 
lighting, and setting Render Global attributes. 

Lighting the scene
The particles are lit independent of other objects in this scene. Two directional lights illuminate 
the rocket, and a spotlight illuminates the particles. A colored point light parented to the back 
of the rocket is also included. See the following.

Creating and placing lights in the scene

Create lights

1 Select Create > Lights.

2 Select the light you want from the menu that displays and click in a view.

3 Adjust the attributes in the light’s Attribute Editor.

A spotlight with linear decay, a slight color tint, wide cone, and high intensity, work well for 
this shot.

4 Select Create > Lights > Spotlight.

5 Set the Linear Decay to Linear.

6 Click the swatch beside Color and select a color to add to the light from the Color Chooser.

7 Set the Cone size to 70.

8 Set the Intensity to 5.

Tip 

To display Maya’s special light manipulators, select the light in the view then press t.
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Light linking

Setting Illuminates by Default off lets you set light linking relationships so certain lights only 
shine on certain objects. 

1 Select Window > Relationship Editors > Light Linking > Light-centric or, 
Lighting/Shading > Light Linking > Light-Centric.

2 Select the particleKey light on the left and the objects you want it to illuminate on the right.

Setting up light linking

Another benefit is that you can use Depth Map shadowing (which renders faster) on lights linked 
to geometry in the scene.

Experiment with placing lights in the scene, or try creating some of your own to see how they 
affect the rendered image.

Using Raytraced Shadows

The scene must be raytraced with raytraced shadows on the lights to apply self-shadowing to the 
particles. To enable raytraced shadows, select the light and turn Raytraced Shadows on in the 
Shadows section of the light’s Attribute Editor. 

Render Globals settings
Many important rendering controls are set in Render Globals (Windows > Render Globals).

The rocket_final.ma scene file contains the Render Global settings for a final quality render. 
When test rendering, you can turn some of these options off to increase the render speed.

Open the Render Globals window to see where to find the following settings and experiment 
with them to see the results they produce.

• Raytracing: Required to invoke particle self-shadowing (found under Raytracing Quality). 
Since Raytracing a scene slows things down considerably (more computation is necessary), 
leave Raytracing OFF until you tune the particle shadows for the final render.
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• Motion Blur: 2D motion blur adds realism to the rocket motion. The particles do not get 
motion blurred. Set motion blur off when test rendering.

• Anti-Aliasing Quality: Set to 3D Motion Blur Production when rendering the final shot. 
Use Preview Quality when test rendering.

• Shadows obey light linking: Located in the Render Options section, this option must be on 
so shadows from particles do not cast onto the rocket (the rocket is lit by different lights).

• Better Illumination: The Better Illumination check box is located just below the Render 
Type setting in the particle object ‘s Attribute Editor. Turn this option on when performing 
final renders only. (This option is only for cloud particles. It increases the quality of the 
lighting on the particles while helping to prevent artifacts and shadow popping.)

CONCLUSION

To recap, this tutorial showed you how to:

• Create particles and emitters

• Parent an emitter to animated geometry

• Adjust particle attributes

• Add fields to affect particle motion

• Keyframe the emission rate in the Graph Editor

• Change the particle radius with respect to particle age

• Assign materials to particles

• Set Render Global options

Without Raytraced Shadows

With Raytraced Shadows

Lit from above and rendered without raytracing.

Raytraced with raytraced shadows.
Also contains shadows within the smoke volume.
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